Magic xpaMagic xpa 3.x製品情報Magic xpa 3.x 動作環境

サイト内検索

Magic xpa Application Platform 3.x 動作環境、サポートDBMS、OS一覧

Magic xpa Application Platform 3.x 動作環境、サポートDBMS、OS一覧

ここでは、Magic xpaのシステム要件を記します。

注意
  • 動作確認レポートのあるものについては、動作確認レポートで確認を行ったソフトウェアバージョン以後が、サポート対象になります。
  • ベンダーからのサポートが終了しているOSやDBMSについては、問題の性質によってはMagicの対応に制限がでてくる場合もありますので、あらかじめご了承ください。

Magic xpa 動作環境

最小ハードウェア要件

 プロセッサ
(相当)
メモリハード
ディスク
ディスプレイ
Magic xpa Enterprise Studio 各OSの最小クロック 各OSの最小メモリ
+2GB
1GB 1024x768
Magic xpa Enterprise Client 各OSの最小クロック 各OSの最小メモリ
+512MB
1GB 800x600
Magic xpa Enterprise Server 各OSの最小クロック 各OSの最小メモリ
+2GB
1GB 800x600
Magic xpa RIA Server 各OSの最小クロック 各OSの最小メモリ
+2GB
1GB 800x600
注意事項
  • プロセッサは、Intel x86アーキテクチャ、およびその互換プロセッサのみサポートしています。
  • 上記の値は最小システム構成であり、パフォーマンスのためには充分に余裕のあるハードウェア構成を推奨します。特に、大きなアプリケーションや大量のデータを処理する場合には、それに見合ったメモリ、ハードディスクを必要とします。
  • この他、利用するDBMSのインストールおよび実行に必要なディスク空き容量、メモリが別途必要です。

サポートOS一覧表

Windows VersionMagic xpa Enterprise StudioMagic xpa Enterprise ClientMagic xpa Enterprise Server
Vista (Business/Enterprise/Ultimate)【x86】 (※3) -
Windows7 (Professional/Ultimate)【x86およびx64】 -
Windows8 (Professional/Enterprise)【x86およびx64】 (※1) -
Windows10 (Pro/Enterprise)【x86およびx64】 -
Server 2008/2008 R2 (Standard, Enterprise) 【x64】
Server 2012/2012 R2  (Essentials/Standard) 【x64】 (※2)
Server 2016  (Essentials/Standard) 【x64】
動作確認レポート 
その他の環境要件
Microsoft .NET Framework 4.0以上※4

Magic RIA(リッチクライアント)

Windows Versionクライアント側サーバ側
Magic xpa RIA Server
Vista (Business/Enterprise/Ultimate)【x86】 (※3) -
Windows7 (Professional/Ultimate)【x86およびx64】 -
Windows8 (Professional/Enterprise)【x86およびx64】

-
Windows10 (Pro/Enterprise)【x86およびx64】 -
Server 2008/2008 R2 (Standard, Enterprise) 【x64】
Server 2012/2012 R2 (Essentials/Standard) 【x64】

Server 2016  (Essentials/Standard) 【x64】
動作確認レポート 

その他の環境要件
Microsoft .NET Framework 4.0以上 4.0以上※4
注意事項
  • x86 (32bit) アーキテクチャの各Windows バージョンをサポートしています。
  • x64 (64bit) Editionについては、Windows Server 2008/2008 R2/2012、Windows7/8/10 についてのみ対応しています。 WOW64上で正常に動作することを確認しております。
    データベースなどサードパーティのソフトウェアを使用する場合は、32Bit環境が必要です。 (例)データベースのクライアントモジュール。
  • Itanium アーキテクチャのWindows上では動作保障されていません。
  • 日本語版の Windows 製品にのみ対応しています。その他の言語バージョンでは、動作保証されていません。
  • ※3: Microsoft社のWindows Vistaサポート終了に伴うMagicの対応について
  • ※4: インストール時に、.NET 3.5の環境が無い場合は、MIMEの設定が行われません。その場合は、手作業でMIMEの設定を行う必要があります。Magic xpa Enterprise Clientでは、MIMEの設定を行いません。

RIA モバイル

Mobile Version

モバイル
RIA Client

iOS Smartphone: iPhone 5/6  iOS 8/9/10

iOS Tablet: iPad 2/iPad 3  iOS 8/9/10
Android Smartphone: Android 4.x(4.0.3以降)/5.x
Android Tablet:     Android 4.x(4.0.3以降)/5.x
注意事項
OSMachine TypeVersionMagic xpa
IBM i Gateway
IBM i
(OS400)
IBM i
(System i,iSeries,
AS/400)
V5R4/V6R1/V7R1/V7R2

サポートDBMS一覧表

DBMS対応バージョン対応状況
Pervasive.SQL Pervasive PSQL v11 for Magic
Actian PSQL v12 for Magic
Oracle

 

Oracle 11g

Oracle 12c

MS-SQL Server   2008/2008 R2
2012
2014
2016
動作確認レポート 
DB2 for IBM i(DB2/400) 対応OSバージョンに準じる
注意事項
  • 各DBMSとも、日本語版にのみ対応しています。
  • その他の言語バージョンのDBMS製品については、DBMSベンダーが日本語版OS上で日本語データの動作保証をしている場合に限り、サポート対象となります。
  • Magic xpa IBM i Gatewayは、Magic xpa 3.0a3でサポート。

その他のソフトウェア要件

用途ソフトウェア対応バージョン
バージョンコントロール用 Microsoft Team Foundation Server

2012
2013
2015
2017

Magic xpa

  • マジックソフトウェア・ジャパンのホームページへ
  • お問い合わせ Contact Us