Magic xpa旧MagicバージョンV10製品情報Magic eDeveloper V10 動作環境

サイト内検索

Magic eDeveloper V10 動作環境、サポートDBMS、OS一覧

eDeveloperMagic eDeveloper V10

Magic eDeveloper V10動作環境、サポートDBMS、OS一覧

ここでは、Magic V10 のシステム要件を記します。

注意:
動作確認レポートのあるものについては、動作確認レポートで確認を行ったソフトウェアバージョン以後が、サポート対象になります。
ベンダーからのサポートが終了しているOSやDBMSについては、問題の性質によってはMagicの対応に制限がでてくる場合もありますので、あらかじめご了承ください。

Magic eDeveloper V10 動作環境

最小ハードウェア要件

 プロセッサ (相当)メモリハードディスクディスプレイマウス
Magic Studio 1GHz Pentium Ⅲ 512MB 400MB 1024x768 必須
Magic Client 600MHz Pentium Ⅲ 256MB 400MB 640x480 -
Magic Enterprise Server 1GHz Pentium Ⅲ 512MB 400MB 640x480 -
Magic RichClient Server 1GHz Pentium Ⅲ 512MB 400MB 640x480 -;
注意事項
プロセッサは、Intel x86アーキテクチャ、およびその互換プロセッサのみサポートしています。
上記の値は最小システム構成であり、パフォーマンスのためには充分に余裕のあるハードウェア構成を推奨します。特に、大きなアプリケーションや大量のデータを処理する場合には、それに見合ったメモリ、ハードディスクを必要とします。
この他、利用するDBMSのインストールおよび実行に必要なディスク空き容量、メモリが別途必要です。

サポートOS一覧表

Windows VersionMagic StudioMagic ClientMagic Enterprise Server
2000 Professional -
2000 Server, Advanced Server
XP Professional -
Server 2003 (Standard, Enterprise)
Vista (Business/Enterprise/Ultimate) -
Server 2008 (Standard, Enterprise) (x86およびx64)
動作確認レポート
Windows7 (Professional/Ultimate) (x86)
動作確認レポート
-
Windows8 × × -
Server 2012 × × ×

Magicリッチクライアント

Windows Versionクライアント側サーバ側
Magic RichClient Server
2000 Professional -
2000 Server, Advanced Server
XP Professional -
Server 2003 (Standard, Enterprise)
Vista (Business/Enterprise/Ultimate) -
Server 2008 (Standard, Enterprise) (x86およびx64)
動作確認レポート
Windows7 (Professional/Ultimate) (x86)
動作確認レポート
-
Windows8 × -
Server 2012 × ×
その他の環境要件
Java Runtime Environment Sun Java RTE 1.5 -
注意事項
x86 (32bit) アーキテクチャの各Windows バージョンをサポートしています。
x64 (64bit) Editionについては、V10.1SP4b以降でWindows Server 2008 についてのみ対応しています。Windows Server 2003 (x86) との互換レベルで動作確認したもので、Windows Server 2008固有の新機能については未検証であり、サポート対象外となります。
Itanium アーキテクチャのWindows上では動作保障されていません。
日本語版の Windows 製品にのみ対応しています。その他の言語バージョンでは、動作保証されていません。
Windows Vistaは、V10.1.J SP2より対応されています。Windows2000/XPとの互換レベルで動作確認したものです。「Tablet PC」機能は、未検証でありサポート対象外となります。
注意2: Windows Server 2003、 Vista、Server 2008 利用時の注意事項
ISAPI および CGI リクエスタを使用する場合、IISマネージャ-Webサービス拡張で実行を許可にしてください。
OSMachine TypeVersionMagic System i GatewayMagic EnterpriseServer
V10for System i
OS400 System i
(iSerise、AS/400)
V5R3 未定
注意事項
Magic Enterprise Server V10 for System i のリリースは、未定です。 Magic Enterprise Server V10 (Winodws版)をご使用ください。

サポートDBMS一覧表

DBMS対応バージョン対応状況
Pervasive.SQL Pervasive.SQL V8 SP3
Pervasive PSQL v9 SP2
Pervasive PSQL v10 動作確認レポート
Pervasive PSQL v11 for Magic
Oracle Oracle 9i R2 (9.2)
Oracle 10g
Oracle 11g ○動作確認レポート
MS-SQL Server 2000 (SP4)
2005
2008 動作確認レポート
DB2 UDB V8.2
DB2/400 対応OSバージョンに準じる
注意事項
各DBMSとも、日本語版にのみ対応しています。
その他の言語バージョンのDBMS製品については、DBMSベンダーが日本語版OS上で日本語データの動作保証をしている場合に限り、サポート対象となります。

その他のソフトウェア要件

用途ソフトウェア対応バージョン
バージョンコントロール用 Microsoft Visual SourceSafe 6.0d SP6、2005
CVS(CVSNT) 2.0.58d

Magic xpa

  • マジックソフトウェア・ジャパンのホームページへ
  • お問い合わせ Contact Us